quinta-feira, 13 de outubro de 2011

Cisco Unified Communications Manager Express SIP Example

voice service voip
allow-connection sitp to sip
sip
bind control source-interface loopback0
register server
!
voice register global
mode cme
source-address 192.168.0.1 port 5060
user-local 1 es
network-locale 1 es
time-format 24
date-format d/m/y
timezone 13
ntp-server 9.9.9.9 mode directed broadcast
load 7965 sip45.9-0.2sr1s
tftp-path flash:
file text
create profile

Incoming PSTN Call Blocking

voice translation-rule 1
rule 1 reject /^399555/
!
voice translation-profile block
translate calling 1
!
dial-peer voice 1 pots
call-block translation-profile incoming block
call-block disconnect-cause incoming invalid-number
incoming called-number .

Enable Router to PSTN Calls - Outbound

dial-peer voice 1 pots
destination-pattern 999
forward-digits all
port0/2/0:15
!
dial-peer voice 2 pots
destination-pattern 9[2-9].......
forward-digits 8
port 0/2/0:15
!
dial-peer voice 3 pots
destination-pattern 9001[2-9]..[2-9]......
forward-digits 13
port 0/2/0:15
// you can use the csim 999 or csim 9444444040 command to simulate the call

Basic Digit Manipulation

num-exp 4... 4005554...
dial-peer voice 4000 pots
destination-pattern 4005554...
forward-digits all
prfix 1
port 0/1:23
!
dial-peer voice 3000 voip
destination-pattern 3...
session-target ipv4:10.1.1.1
!
dial-peer voice 3001 pots
destination-pattern 3...
prefix 13005553
preference 1
port 0/1:23

Auto Register Cisco IP Phones

telephony-service
max-ephone5
max-dn 10
create cnf-files
ip source-address 10.10.10.1
auto assign 1 to 2
!
ephone-dn 1 dual-line
number 1001
!
ephone-dn 2 dual-line
number 1002

quarta-feira, 12 de outubro de 2011

10 steps to configure Cisco Call Manager Express

STEP 1
Configuring a Switch Trunk Port
SwitchA(config-if)# switchport trunk encapsulation dot1q
SwitchA(config-if)# switchport mode trunk
Creating VLANs
SwitchA# configure terminal
SwitchA(config)# vlan 10
SwitchA(config-vlan)# name VOICE
SwitchA(config-vlan)# exit
SwitchA(config)# vlan 50
SwitchA(config-vlan)# name DATA Assigning Switchport to a VLAN
SwitchA# configure terminal
SwitchA(config)# interface fa0/10
SwitchA(config-if)# switchport mode access
SwitchA(config-if)# switchport access vlan 50
Assigning Voice and Data VLANs
SwitchB# configure terminal
SwitchB(config)# interface range fa0/1 - 4
SwitchA(config-if-range)# switchport mode access
SwitchA(config-if-range)# switchport access vlan 50
SwitchA(config-if-range)# switchport voice vlan 10
Configuring a Trunk to the CME Router
SwitchA# configure terminal
SwitchA(config)# interface fa0/20
SwitchA(config-if)# description CONNECTION TO ROUTER-ON-A-STICK CME ROUTER SwitchA(config-if)# switchport trunk encapsulation dot1q
SwitchA(config-if)# switchport mode trunk

STEP 2
Configuring Inter-VLAN Routing
Router# configure terminal
Router(config)# interface fa0/0
Router(config-if)# no ip address
Router(config-if)# exit
Router(config)# interface fa0/0.10
Router(config-subif)# description ROUTER INTERFACE FOR VOICE VLAN
Router(config-subif)# encapsulation dot1q 10
Router(config-subif)# ip address 172.16.1.1 255.255.255.0
Router(config-subif)# ip helper-address 172.16.2.5
Router(config-subif)# exit
Router(config)# interface fa0/0.50
Router(config-subif)# description ROUTER INTERFACE FOR DATA VLAN
Router(config-subif)# encapsulation dot1q 50
Router(config-subif)# ip address 172.16.2.1 255.255.255.0

STEP 3
Configuring a Router-Based DHCP Server
RTR# configure terminal
RTR(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.9
RTR(config)# ip dhcp excluded-address 172.16.2.1 172.16.2.9
RTR(config)# ip dhcp pool DATA_SCOPE
RTR(dhcp-config)# network 172.16.2.0 255.255.255.0
RTR(dhcp-config)# default-router 172.16.2.1
RTR(dhcp-config)# dns-server 4.2.2.2
RTR(dhcp-config)# exit RTR(config)# ip dhcp pool VOICE_SCOPE
RTR(dhcp-config)# network 172.16.1.0 255.255.255.0
RTR(dhcp-config)# default-router 172.16.1.1
RTR(dhcp-config)# option 150 ip 172.16.1.1WAN_RTR(dhcp-config)# dns-server 4.2.2.2

STEP 4
Setting the Clock of a Cisco Device with NTP
WAN_RTR# configure terminal
WAN_RTR(config)# ntp server 64.209.210.20
WAN_RTR(config)# clock timezone Cairo +2

STEP 5
Installing CME Files into Flash Memory
CME_Voice# archive tar /xtract tftp://172.16.2.5/cme-full-4.3.0.0.tar flash:

STEP 6
Configuring Router-Based TFTP Services for IP Phone Firmware Files
CME_Voice# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
CME_Voice(config)# tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
CME_Voice(config)# tftp-server flash:/phone/7940-7960/P00308000500.loads alias P00308000500.loads
CME_Voice(config)# tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
CME_Voice(config)# tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn

STEP 7
Configuring the Cisco Unified CME System-Level Functions
Provisioning CME Phone and Directory Number Support
CME_Voice(config)# telephony-service
CME_Voice(config-telephony)# max-ephones ?
<1-30> Maximum phones to support
CME_Voice(config-telephony)# max-ephones 24
CME_Voice(config-telephony)# max-dn ?
<1-150> Maximum directory numbers supported <cr>
CME_Voice(config-telephony)# max-dn 48
Configuring CME for 7970 and 7971 Firmware Loads
CME_Voice(config)# tftp-server flash:/phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
CME_Voice(config)# tftp-server flash:/phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
CME_Voice(config)# tftp-server flash:/phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-27.sbn
CME_Voice(config)# tftp-server flash:/phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
CME_Voice(config)# tftp-server flash:/phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-27.sbn
CME_Voice(config)# tftp-server flash:/phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
CME_Voice(config)# tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loads
CME_Voice(config)# tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loads
load 7970 SCCP70.8-3-3S.loads
Updating CNF files CNF files update complete
 CME_Voice(config-telephony)# load 7971 SCCP70.8-3-3S.loads
Updating CNF files CNF files update complete

STEP 8
Source IP Address Information
CME_Voice(config)# telephony-service
CME_Voice(config-telephony)# ip source-address 172.16.1.1

STEP 9
Generating IP Phone Configuration Files
CME_Voice(config-telephony)# create cnf-files
CNF file creation is already On
Updating CNF files
CNF files update complete

STEP 10
Verifying Files Served by the CME TFTP Service
CME_Voice# show telephony-service tftp-bindings
tftp-server system:/its/SEPDEFAULT.cnf
tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf
tftp-server system:/its/XMLDefault.cnf.xml alias XMLDefault.cnf.xml
tftp-server system:/its/ATADefault.cnf.xml
tftp-server system:/its/united_states/7960-tones.xml alias
United_States/7960-tones.xml